Officefull.es

Excel, word, powerpoint, android

Número a letras Excel sin Macros abril 11, 2008

¿CÓMO CONVERTIR UNA CIFRA NUMÉRICA A LETRAS EN EXCEL SIN MACROS?

La versión del siguiente archivo esta desarrollada para la utilización de sus fórmulas en cualquier hoja de nuestro libro.

En el Artículo anterior:

Número a Letras Excel

Pesos, Dólares, Euros, Libras, medidas de longitud, capacidad o masa ….

Convertir número a letra sin macros

DESARROLLO VERSIÓN II

En esta versión se van a utilizar los nombres definidos, podemos definir un nombre para un rango de celdas, para una función, para una constante o para una tabla.

Los Nombres definidos nos ayudan, nos facilitan, nos dan comprensión, nos dan luz cuando estamos trabajando con un rango, constante o tabla en nuestro libro de Excel y poder utilizar dichos nombres definidos en todas nuestras hojas de cálculo cuando lo necesitemos

Si utilizamos una configuración regional donde el punto decimal es la coma (como puede ser la configuración regional española), es importante que leáis las anotaciones del final del artículo.

Abrir el archivo que podéis descargaros – EnLetrasSinMacros Vesion II.zip (6.63 kB)

Una vez abierto, deteneros a observar la hoja [ EnLetraSINMacrosV2] para ver como están estructuradas todas sus fórmulas

EnLetraSinMacros Version II

Observamos las constantes utilizadas

En las celdas A2 y A3 deberemos de poner nuestra unidad monetaria ya sea el Euro, el Dólar, Pesos…, bien poner medidas de longitud, capacidad o masa….

La celda A4 según nuestra necesidad, si queremos ver por ejemplo las fracciones de moneda con número o bien con letra

cantidad numerica a letras excel

Fórmulas utilizadas para la creación de los nombres definidos

Para poder ver los nombres definidos en Excel Versiones Excel 2000-XP-2003
Menú – insertar – Nombre – Definir

Versión Excel 2007-2010
Ficha Fórmulas – grupo de botones – Definir nombre – Administrar Nombres.

Nombres definidos

Nombres Definidos utilizados para convertir los números en letras

=EnLetra – Nos dará la cantidad en letras minúsculas.

=EnFrase – Nos dará la cantidad en letras tipo Oración.

=EnPropio – Nos dará la cantidad mayúscula cada palabra.

=EnMayusc – Nos dará la cantidad en letras mayúscula.

Cantidad a letras Excel

cantidad númerica a excel

¿CÓMO UTILIZAR ESTOS NOMBRES DEFINIDOS?

Una vez hemos escrito nuestras constantes en la celda A2, A3 y A4 [Pesos, Euros, Dólares, bolívares ….] de la hoja [ EnLetraSINMacrosV2 ] , entonces pasamos a nuestra hoja [ Datos ]

hoja datos

La columna B podemos personalizar el formato de las celdas al gusto [moneda o aplicar un formato personalizado]

Y en la columna C es donde vamos a aplicar nuestros nombres definidos mediante una fórmula muy sencillita según el nombre definido que vayamos a aplicar también a gustos

Si necesitamos el nombre definido =EnFrase

=SI(B2=””,””,EnFrase), que podemos arrastrar hacia abajo tantas celdas como cantidades necesitemos convertir a Letras

EnFrase

Si necesitamos el nombre definido =EnLetra

=SI(B2=””,””,EnLetra)

EnLetra

Si necesitamos el nombre definido =EnPropio

=SI(B2=””,””,EnPropio)

EnPropio

O el nombre definido =EnMayusc

=SI(B2=””,””,EnMayusc)

En Mayúscula

ANEXO PARA LA MONEDA PESO

Para el caso de que necesitáramos tener nuestra cantidad como el caso siguiente

CUARENTA Y CINCO MIL SETECIENTOS TREINTA Y SIETE PESOS CON 98/100 M.N

Numeros a letras Excel

Debemos variar la siguiente celda en la hoja EnLetraSINMacrosV2, Celda A3 y en esta celda introducimos el valor /100 precedido de un apóstrofe [ ‘ ] introduciendo en la celda el valor así: ‘/100

Numeros a letras Excel

Y en la [Hoja datos] añadir “M.N”, que siguiendo con el ejemplo del artículo quedaría así =SI(B3=””,””,EnPropio&” M.N”)

Numeros a letras Excel

ANOTACIONES

No importa cual sea la celda “activa” al momento de definir/crear/… cualquiera de los nombres, EXCEPTO y SOLO…cuando se define el nombre “_A” es importantísimo que la celda activa mantenga…una “relatividad” apropiada: Si la cantidad (valor número) estuviera en la celda (digamos…) [G5] y se requiere que el importe en letras aparezca en la celda [M7]:

[M7] deberá ser la celda activa al definir el nombre (_A) usando la fórmula:

=texto(!g5,”000000000000000.00″)&repetir(“”,0*hoy())

que se puede “recortar” a:

=texto(!g5,”000000000000000.00″)&t(hoy())

Debemos de modificar el nombre definido (_A) estando en la celda [ M7 ] así, cuando “se llame” al nombre, aparecerá (En la celda donde se utilice) el importe en letras correspondiente a la celda “relativa”, en este caso, el valor numérico será el que este a la distancia de -2 filasy -6 columnas:

Porque…

  • – al estar el importe en la celda [G5]
  • – y teniendo como celda “activa” [M7] al momento de crear el nombre (_A)
  • – la “relatividad” (entre una y otra celdas) es de +/- 2 filas y +/- 6 columnas

Nombre definido (  _A )

Otro dato a tener en cuenta es:

El signo ‘!’ (unión entre hoja y rango) cuando se define un nombre y se selecciona una celda, Excel complementa con el nombre de la hoja y una referencia absoluta ($) esto significa que “el nombre” queda vinculado (de forma absoluta) con “la celda” de “esa” hoja, sí antes de aceptar, se ELIMINA (de la formula “corregida” por Excel) la parte con el nombre de la hoja, PERO… se conserva el signo ‘!’, las siguientes llamadas a ese “nombre” conservan la referencia de celda PERO… la vinculación a “la hoja” será a la hoja “activa.

Si utilizamos una configuración regional donde el punto decimal es la coma como puede ser la configuración regional española:

Entonces debemos de cambiar con cuidado el Punto por la Coma en el nombre definido (_A) :

De:

Numero a letras

a:

Numero a letras

Sí queremos que nuestros números a letras NO lleven monedas, ni medidas de longitud, capacidad o masa:

1.- Dejaremos en blanco las constantes

Constantes en blanco

2.- Y Cambiaremos el siguiente nombre definido _L5

Sólo números a letras sin monedas ni únidades capacidad

De

=_b52&si(o(–derecha(_a5,2)>15,–derecha(_a5,2)<10),indice(_1,1+derecha(_a5))&si(y(–derecha(_a5)=1,derecha(_0a)=”a”),”a”,si(_0a=””,”o”,””))&si(y(_0a<>””,–derecha(_a5)>0),” “,””),””)

a…

OJO con el separador de argumentos utilizados en las fórmulas, SI da error la formula, debemos comprobar si utilizamos la coma [ , ] o el punto y coma [ ; ]

Op1

=_b52&si(o(–derecha(_a5,2)>15,–derecha(_a5,2)<10),indice(_1,1+derecha(_a5))&si(y(–derecha(_a5)=1,derecha(_0a)=”a”),”a”,si(y(–derecha(_a5)=1,_0a=””),”o”,””))&si(y(_0a<>””,–derecha(_a5)>0),” “,””),””)

ó Bien…Op2

=_b52&si(o(–derecha(_a5,2)>15,–derecha(_a5,2)<10),indice(_1,1+derecha(_a5))&si(–derecha(_a5)=1,si(derecha(_0a)=”a”,”a”,si(_0a=””,”o”,””)),””)&si(y(_0a<>””,–derecha(_a5)>0),” “,””),””)

Habréis comprobado esta Versión II creada por Héctor Miguel Orozco nos da la facilidad de utilizar los Nombres definidos para poderlo aplicar a todas nuestras hojas facilitándonos así nuestra conversión de números a literales.

 

Categorías: Sin categoría

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *