Officefull.es

Excel, word, powerpoint, android

Round Robin Excel Marzo 8, 2009

Encuentros Deportivos

Round Robin (algoritmo de planificación por turnos rotatorios), método empleado en sistemas de competición deportiva, todos contra todos. En el siguiente artículo os mostraremos como podéis organizar a los participantes de una competición deportiva.

El calendario está preparado para 20 jugadores (10 encuentros por fecha) pero se puede agregar mas, ampliándolo a partir de la columna O y de la fila 25 arrastrando las fórmulas previas correspondientes.

Calendario de Encuentros

Considerando “E#” como el “Encuentro numero X”, “F#” como la “Fecha numero X” y “n” como el numero de registros, el principio básico para la determinación de los encuentros (Round-Robbin o “todos contra todos”)SIN repeticiones es:

=E#+(E#>1)*F#-(((E#+F#)>n))*(n-1)&"-"&E#+F#-(E#>1)*(E#+(E#-2))+((E#+F#-(E#+(E#-2))<2)*(n-1))

Rango de celdas E2:N24

=SI(Y(E$3,$A5,$A5<$B$1),INDICE($C$4:$C$25,COINCIDIR(E$3+(E$3>1)*$A5-(($B$1-1)*((E$3+$A5)>$B$1)),$A$4:$A$25,))&"-"&INDICE($C$4:$C$25,COINCIDIR(E$3+$A5-(E$3>1)*(E$3+(E$3-2))+(($B$1-1)*(E$3+$A5-(E$3+(E$3-2))<2)),$A$4:$A$25,)),"")

Desarrollo del Archivo Round Robin

Columna B

Inscritos (jugadores, equipos,…) donde se van a ir rellenado con los nombres correspondientes para ir completando pares. Podéis comprobar la “secuencia” en la que se programan los encuentros solo cambiando los “nombres” por números (1,2,3,4…)

[Celda B1] =MAX(A4:25)

Columna C

Es de donde se distribuyen los nombres a la tabla de encuentros y complementa los “impares” con un encuentro “Libre” (texto en blanco).

=SI(B5<>"",B5,SI(Y(B4<>"",B5="",RESIDUO(FILAS(B$5:B5),2)=0),"Libre",""))

Columna D

=A8*(A8<$B$1)

Es la establecida para las fechas con un formato de celda para el ejemplo del archivo “Fecha” 0;;””; el cual puedes cambiar por ejemplo a “Fecha ” dd/mmm/yyyy;;””; ó dependiendo de vuestra configuración regional“Fecha ” dd/mmm/aaaa;;””; de tal manera que al introducir la fecha 1 de marzo de 2009 quede como veis en la imagen

Columna A

Esta columna se auto-numera en números pares (se requieren 2 para que haya 1 encuentro).

=(C5<>"")*FILAS(B$5:B5)

Rango de celdas E1:N1

Formato de Celdas personalizable al gusto “Encuentro” 0;;””;

=(COLUMNAS($E1:I1)<=$B$1/2)*COLUMNAS($E1:I1)

Comentarios adicionales

Una vez creado nuestro calendario, si suprimimos un nombre inscrito en la lista y éste forma parte de los pares intermedios, el archivo nos avisa de que hemos dejado un nombre en blanco.

El archivo lleva una hoja oculta llamada “Xl” para poder visualizarla abrimos el editor de Visual Basic [atajo de teclado ALt + F11 ] >> Menú Ver >> Ventana Inmediato [Atajo de teclado Ctrl + G ] >> aplicar la siguiente línea de código y [Enter]

sheets(“xl”).visible=true

En ella encontraremos la celda A1 la cual hace referencia el control de imagen de la hoja Round Robbin

Formatos condicionales

El archivo lleva el siguiente formato condicional:

 =ESNUMERO(HALLAR("libre",E5))

El cual nos indica qué nombres inscritos en la lista están libres.

Descarga de Archivo para pruebas

Round Robin -Fixture- (10.66 kB)

Enlaces de Interés

Planificación Round-robin

http://es.wikipedia.org/wiki/Planificacion Round-robin

Agregar, cambiar o borrar formatos condicionales (Excel 2007)

http://office.microsoft.com/es-es/excel/HP100739393082.aspx

Agregar, cambiar o quitar formatos condicionales (Excel 2003)

http://office.microsoft.com/es-es/excel/HP051992783082.aspx

Categorías: Sin categoría

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *